Index

Install N1ED add-on on TinyMCE 4 and TinyMCE 5

Installing N1ED in TinyMCE 4 and TinyMCE 5 is basically standard installing of an add-on in TinyMCE.

  1. Download the add-ons in "Downloads" section of your Dashboard.

  2. Place the downloaded plugins to tinymce/plugins folder:

tinymce/
    plugins/
        N1ED/
        Flmngr/
        ImgPen/
        Translator/
  1. Edit tinymce.init(). Specify add-ons you have purchased in plugins:
plugins: 'N1ED Flmngr ImgPen Translator,'
  1. Install Flmngr on the server and specify these URLs in tinymce.init(). For example:
urlFileManager: 'https://example.com/filemanager',
urlFiles: 'https://example.com/files/',
  1. Specify API key for YouTube in the client config for using this widget. This key is free and can be retrieved at Google Developer Console. For example:
widgets: {
    'YouTube': {
        'apiKey': 'my-API-key'
     }
}
  1. For correct work of Font Awesome widget add this parameter images_dataimg_filter:
images_dataimg_filter: function(img) {
   return img.hasAttribute('internal-blob');
}

That's it. Now you are ready to use N1ED.